Industrial Park

From BFBB Wiki
Jump to: navigation, search

Introduction[edit]

Industrial Park is a tool made by community member igorseabra4 in C# using SharpDX. It is an editor capable of opening a number of HIP/HOP files and display the level, with models and textures for level and objects, as well as edit some of the asset types. The program is still under development, so features are still planned; the latest release version is Preview 17 and the information on this page is up to date with it.

This tool is based off from, and shares a lot of its source code with another one of the creator's tools: Heroes Power Plant, a tool to edit levels in Sonic Heroes. Being also based on the RenderWare engine, both games share their model format. It also gave Industrial Park the convention of being named after a level in the game.

Industrial Park Screenshot1.png Industrial Park Screenshot2.png

Game/Platform Compatibility[edit]

GameCube Xbox PS2 PC
Scooby-Doo: Night of 100 Frights Minimal support Minimal support Minimal support -
Spongebob Squarepants: Battle for Bikini Bottom Supported Supported Minimal support -
The Incredibles Supported Supported Minimal support Minimal support
The Spongebob Squarepants Movie Supported Supported Minimal support -
The Incredibles: Rise of the Underminer Minimal support Minimal support Minimal support Minimal support

Usage[edit]

View[edit]

These are the commands to move the view:

  • W, A, S, D: move view forward, left, backward, right
  • Shift + (W, S): move view up, down
  • Ctrl + (W, A, S, D): rotate view up, left, down, right
  • Q, E: decrease interval, increase interval (view move speed)
  • 1, 3: decrease rotation interval, increase rotation interval (view rotation speed)
  • R: reset view
  • Z: toggle mouse mode
  • F1: displays the View Config box

Mouse controls:

  • Mouse wheel to move forward/backward
  • Right click and drag to pan (move view up, left, down, right)
  • Middle click and drag to rotate view
  • Left click on an asset to select it
  • Ctrl + Left click on an asset to select multiple

Mouse mode (Z): similar to a first person camera. The view rotates automatically as you move the mouse. Use the keyboard to move around.

Options[edit]

In the Options tab, you can choose a few settings.

  • View Config (F1): displays the View Config box.
  • Add Texture Folder: explained below.
  • Clear Textures: clear textures from program.
  • Use Legacy Asset ID Format: disables using asset names in place of IDs
  • Colors:
    • Reset: resets all colors to default.
    • Background: allows you to choose a new background color for the view.
    • Widget: allows you to choose a new color for unselected box widgets.
    • MVPT: allows you to choose a new color for unselected MVPT widgets.
    • TRIG: allows you to choose a new color for unselected TRIG widgets.
    • SFX: allows you to choose a new color for unselected SFX widgets.
    • Selection: allows you to choose a new color for selected widgets and objects.
  • No culling (C): toggles backface culling
  • Wireframe (F): toggles wireframe mode
  • Use Legacy Asset ID Format: this will disable using asset names in Asset ID fields and force you to use hex numbers only.
  • Name Display Mode: Choose how asset names will be displayed:
    • AssetName [AssetID] (default)
    • [AssetID] AssetName (alternate)
  • About: display About box.

In the Display tab, you can choose which asset types are currently being displayed. You can also toggle #UI Mode (U).

View Config[edit]

The view config allows you to view and set Industrial Park's 3D view's current position, rotation, movement speed (separate for position and rotation), maximum draw distance and field of view.

View Config window

Projects[edit]

Industrial Park projects are a resource to help users with level editing. A project file is a text (JSON) which saves an open instance of the program, meaning it contains:

  • Opened HIP/HOPs and texture folders
  • View position, rotation, FOV, draw distance, speed
  • Settings sucha as wireframe, culling and custom colors
  • Which assets are currently visible

All of those are restored from the file, meaning you can quickly restore Industrial Park to a previous state.

  • Project Menu:
    • New: closes the current project instance and resets Industrial Park to default.
    • Open: choose a project JSON to open.
    • Save: saves the current instance as a project JSON, overwriting the previous one. Does not save edits on HIP/HOP files on the Archive Editors.
    • Save As: saves the current instance as a new project JSON. Does not save edits on HIP/HOP files on the Archive Editors.
    • Auto-Save On Closing: automatically saves the currently open project JSON when closing Industrial Park.
    • Auto-Load On Startup: automatically loads the previously open project JSON when opening Industrial Park.

If Auto-Save On Closing is enabled and no project JSON is specified, a file called default_project.json in the same directory as Industrial Park will be created and used. Project files can be opened and edited in a text editor, where you can manually edit them if you want to, although I don't recommend doing this.

Archive Editor[edit]

The archive editor is the main way to edit HIP/HOP archives in Industrial Park. You can open any amount of Archive Editors you want to, and each can have one HIP and/or HOP file open. If you wish to edit multiple HIP/HOP files for a level, for example, you can open two Archive Editors each with one of the files. Also, opening a third one with boot.HIP will allow you to view the objects whose models are contained there (such as spatula, underwear and shiny objects).

Archive Editor window
  • File Menu:
    • Open: choose a HIP/HOP file to open in this Archive Editor. If the file is from Scooby-Doo: Night of 100 Frights, a dialog will ask you to choose which platform that file corresponds to (GameCube, PS2, XBOX) as it's not possible to determine that from the file in that game.
    • Save: saves the currently open file and overwrites it.
    • Save As: allows you to pick a new destination to save the file.
    • Export TXD Archive: Allows you to export all of the archive's RWTX assets into a single TXD file. This only works on GameCube HOPs.
    • Import TXD Archive: Allows you to choose a TXD file to import; rather than importing the entire archive, the tool will batch create one asset from each texture of the archive and import it as a RWTX asset. Existing ones with matching names/IDs will be replaced.
    • Close: closes this Archive Editor and unloads the HIP/HOP file. This doesn't save the file.

Closing the Archive Editor through the X button will not close it, only hide it.

  • Layer: assets in HIP/HOP archives are organized into layers. Each layer has a list of assets and if you're adding new assets you should add them to the appropriate layer (for example, models should go in a MODEL layer).
    • Layer Box: this will allow you to pick a layer and view its assets.
    • Layer Type: this will allow you to see and edit a layer's type.
    • Add: this will add a new layer to the archive.
    • Remove: this will delete the selected layer from the archive along with all its assets.
    • Move Layer Up: this will move the selected layer up in the list. This is useful as Texture layers must come before all others in the HOP.
    • Move Layer Down: this will move the selected layer down in the list.
  • Assets: each asset is an individual in-game object with a type and function. You can click on an asset in the list to select it, or Ctrl + click to select multiple.
    • Show by type: this will allow you to see in the list only assets of a specific type, or all of them.
    • Find Asset: type an asset ID (preceded by 0x) or name here. If an asset with this ID or name is present, it'll be selected.
    • Add: displays the #Asset Header Editor, allowing you to create a new asset.
    • Duplicate: duplicates the selected asset(s). The new assets will be a copy with a new name and asset ID.
    • Copy: puts the selected assets on clipboard. You can paste them to a text file and save it, or paste in a different Archive Editor, for example.
    • Paste: pastes the assets from clipboard. You must have previously copied assets. If the asset already exists, it'll be given a new name and asset ID.
    • Remove: deletes the selected assets from the archive.
    • View: will move the view to the selected asset's position. For most assets, it will show the asset from a short distance, but for the CAM asset, it will place the view in the exact position it assumes ingame for that camera.
    • Export Raw: allows you to export an asset's raw data to a file. If multiple assets are selected, you'll be able to export them to a folder.
    • Edit Header: displays the #Asset Header Editor, allowing you to edit the selected asset's header.
    • Edit Data: displays the Asset Data Editor dialog, allowing you to edit the selected asset's internal data. This editor is only available for some of the assets; for the others, you must export the raw data and edit it externally in a hex editor. Pressing G is a shortcut to this button.

Notes:

  • You can click on an asset in the view to select it in the Archive Editor, or Ctrl + click to select multiple.
  • If moveable assets are selected, a transform gizmo will be displayed. You can click and drag these arrows to move the object around the world.

Asset Header Editor[edit]

The Asset Header dialog will be shown when adding or editing an asset.

Asset Header Dialog

It allows you to edit the information of the asset's AHDR entry. Header data is the same for all asset types.

  • Asset Type: the type of the asset. If you change this, be sure to import new asset data.
  • Asset ID: the Asset ID of the asset. It'll be calculated automatically from the asset name using the BDKR hash algorithm, which is the same one used originally by the developers, but you can edit it afterwards (don't do this for RWTX assets!)
  • Flags: these are dependant on asset type. It's best if you do not change them.
  • Asset Name: the name of the asset. The name and asset ID are important for identifying your asset in the archive and referencing it from other assets.
  • Asset Filename: the path to the asset's data for external data. This was used only during development and is ignored, so there's no need to bother with this.
  • Checksum: this was used only during development and is ignored, so there's no need to bother with this.
  • Grab Template: for some assets, a template is available, allowing you to create a blank version of the asset without copying it or importing raw data. You can add your templates under Resources\Templates\<Game Name>\ if you want to (templates are unique to Scooby and BFBB but are shared between Incredibles, Movie Game and ROTU).
  • Import Raw Data: imports the asset's raw data from a file.

Asset Data Editor[edit]

The Asset Data editor will be shown when editing an asset's internal data.

Asset Data Editor for SIMPs
Asset Data Editor for TEXTs

This window has different properties for each asset, and sometimes looks completely different as it's adapted for each individual asset types's needs (such as CAM, SND, SNDS and TEXT). Not all of the asset's attributes are known, meaning you'll find a lot of fields labeled as unknown. This editor is not available for all asset types, and you can find the list for which it does work below.

The internal editor supports conversion between asset IDs and asset names. This means that, in any place you're supposed to type an asset ID, you can also type the name and the ID will be generated automatically from it; asset IDs will also be automatically replaced by names whenever possible. Type hexadecimal numbers starting with 0x to force use of an asset ID and not a name. This function can be turned off completely in the options: "Use Legacy Asset ID Format".

The button labeled "Find Who Targets Me" performs a backwards search of assets, finding which assets have a field or an event that target "me" (for example, if you perform this on a MODL, you'll find which MINFs, SIMPs or PLATs use it).

Asset Types[edit]

The following asset types are supported by the internal editor:

Asset Status Info
ANIM Edit ANIM editor is very rudimentary as not all is known about the format.
ALST Edit
BOUL Edit, Display from model
BSP Display BSP models will be displayed in the world. You can import new ones made in other editors/exporters, but Industrial Park doesn't have converting or editing features.
BUTN Edit, Display from model
CAM Edit, Display as widget The view button will place Industrial Park's view in the exact position the camera assumes ingame. The internal editor features functions to get the position and direction of the camera from Industrial Park's view. Be careful not to click these buttons when the view is not where you want the camera to be!
CNTR Edit
COND Edit
DPAT Edit
DSCO Edit
DSTR Edit, Display from model
DYNA Edit, Display as widget Allows editing of almost all DYNA types in BFBB, but not TaskBox.
EGEN Edit, Display from model
ENV Edit
FOG Edit Allows editing of fog settings and colors. Click the [...] button next to the color value to show a color picker.
GRUP Edit
HANG Edit, Display from model
JSP Display JSP models will be displayed in the world. You can import new ones made in other editors/exporters, but Industrial Park doesn't have converting or editing features.
MAPR Edit
MINF Use for display MINF assets cannot be edited, but they will be used to find a MODL to display assets as.
MODL Display Assets with references to MINF or MODL will be displayed as that model in the world. You can import new DFFs made in other editors/exporters, but Industrial Park doesn't have converting or editing features.
MRKR Edit, Display as widget
MVPT Edit, Display as widget
PEND Edit, Display from model
PICK Edit, Use for display PKUP assets will try to find their models from the references in the PICK asset, so for that, boot.hip must be opened in an Archive Editor. Otherwise, the PKUPs will be displayed as widgets.
PIPT Edit
PKUP Edit, Display from model
PLAT Edit, Display from model
PLYR Edit, Display as widget
PORT Edit
SFX Edit, Display as widget SFX assets have a minimum and a maximum radius. The maximum will be only displayed if the asset is selected.
SHDW Edit
SIMP Edit, Display from model
SND, SNDS Import raw When importing an SND or SNDS asset, you have two choices:
  • Trim the sound's header and send it to the SNDI asset. This will cut the header from your data and send it to the SNDI asset, which holds the headers of SND and SNDS.
  • Import the sound's data as it is. This will not mess with the SNDI asset.
SNDI Edit
  • The SNDI asset can be edited individually, and can also be updated automatically from a SND or SNDS import.
  • If you already have your sound in its SND/SNDS but not here, you can also import the header individually by clicking the [...] button next to the 'SoundHeader' property (this will take just the header in case you select the entire sound file)
SURF Limited editing Doesn't allow you to edit all fields yet.
TEXT Edit
TIMR Edit
TRIG Edit, Display as widget
UI Edit, Display from model/texture Texture UIs display properly, model UIs are slightly off.
UIFT Edit, Display from model/texture Texture UIs display properly, model UIs are slightly off, displaying as text is not supported yet.
VIL Edit, Display from model

Displaying Textures[edit]

You may have noticed that, when you first open a level, it has no textures. Industrial Park cannot load textures directly from the RWTX assets contained in the HOP yet. To enable texture display, you must use Magic.TXD.

  1. In the Archive Editor in which you've opened the HOP file, click File -> Export TXD Archive. Choose a path and name to save your TXD as.
  2. Open your new TXD file in Magic.TXD and click Export -> Export All. Set the format to PNG and choose any folder to export all your textures to. Now close Magic.TXD.
  3. Now that you have all textures exported to a folder, you can use Industrial Park's Add Texture Folder button to load these textures in.

UI Mode[edit]

In the Display tab, or by pressing U, you toggle between normal view mode and UI Mode: this is intended for editing of menus through UI and UIFT assets. The view will become a 2D 640x480 screen (this aspect ratio can be forced through the UI Mode AutoSize button). Those assets can also be edited in normal mode, but it's possible to have an approximate preview of them with UI Mode.

Industrial Park in UI Mode

Links[edit]